#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    1
    Rep Power
    0

    C API version mismatch


    Hey there..

    I work on Knoppix 3.4 (HDD install) .I am new to Linux, and am working on a project on developing a module of the Zope Product GNOWSYS. I have to work on zope 2.6.2 for compatability reasons.

    I have installed zope, and while instantiating GNOWSYS, the connection is broken and i get the following in the terminal :

    WARNING: Python C API version mismatch for module multiarray:
    This Python has API version 1010, module multiarray has version 1011.

    I need to get started with my project so.. could anyone help me out please...
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Feb 2004
    Location
    London, England
    Posts
    1,585
    Rep Power
    1373
    It sounds like the version of numpy/Numeric that you have installed is not compatible with the python version used by Zope. Download the correct version from http://sourceforge.net/project/showf...ackage_id=1351.

    If you are on a linux/unix system you will probably need to compile it from source.

    I think the version of Zope you are using runs on Python 2.1, so try installing Numeric-18.4.1-Python-2.1.tar.gz.

    Dave - The Developers' Coach

IMN logo majestic logo threadwatch logo seochat tools logo