#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2005
    Posts
    49
    Rep Power
    0

    Python 2.3.4 IDLE GUI Problem on Windows XP PRO


    Hey all,

    I donwloaded the Python2.3.4. the command line version works properly. but when i try using the IDLE , it doesnt even respond.

    First : The IDLE doesnt run from start- program - python23 -IDLE

    Second : If i have a Python file, right click - open with IDLE even that doesnt work.

    I even tried re installing the s/w.

    I am using Win Xp pro - ver 2002.

    Please let me know a solution to this at the earliest, i have my project pending.

    Any help will be appreiciated.

    thanks

    Arpan
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2004
    Posts
    461
    Rep Power
    25
    well if the command line is working, then you don't really need the idle to script. Just use like notepad or some other text editor, then give it a .py extention. Navigate your way to it with cmd and execute.
  4. #3
  5. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,642
    Rep Power
    4247
    Try installing PythonWin too. IMHO, I prefer PythonWin's editor anyway.
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo
  6. #4
  7. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2005
    Location
    The Holographic Universe
    Posts
    75
    Rep Power
    10
    Hi, I've had some similar problems with IDLE. When IDLE launches it uses your computer's loopback interface so check that your firewall settings aren't interferring with its initialization. Also, try checking the Application Event Log from Administrative Tools to see if there are any recorded issues there. I have also found that the 'Edit with IDLE' shell command is broken on my system, so I removed it. If you are using Windows for you development I would go with Scorpions4ever's advice.

IMN logo majestic logo threadwatch logo seochat tools logo