#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2005
    Posts
    4
    Rep Power
    0

    wxPython window theme


    Hi guys! (and girls :P)

    I've been coding a little program for resizing images, but I haven't been able to get a nice GUI theme working..

    When running the program from IDLE it looks like this:


    But when I compile it using Py2Exe and run the executable, it looks like this:


    How can I get my prog to look like the first image?

    Thanks in advance!
  2. #2
  3. Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Dec 2004
    Location
    Meriden, Connecticut
    Posts
    1,797
    Rep Power
    154
    They both look the same to me. Only the title bar has a different version. Is that what you're referring to? If so, for whatever (stupid) reason, wxPython may have did some kind of rounding to your number, but that in itself wouldn't even make sense.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2005
    Posts
    4
    Rep Power
    0
    Originally Posted by †Yegg†
    They both look the same to me. Only the title bar has a different version. Is that what you're referring to? If so, for whatever (stupid) reason, wxPython may have did some kind of rounding to your number, but that in itself wouldn't even make sense.
    hehe, the version number is my mistake (old screenshot)..

    no, the differences i'm referring to are:
    -round vs. rectangle button
    -listbox edges

    just open them in 2 windows and alt-tab between the two.. you'll see what i mean

    thanks again
  6. #4
  7. Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Dec 2004
    Location
    Meriden, Connecticut
    Posts
    1,797
    Rep Power
    154
    I know what you're talking about now. However I have no clue what would cause such a thing. If I think of anything that could have, I'll make another post.
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2005
    Posts
    4
    Rep Power
    0
    Originally Posted by †Yegg†
    I know what you're talking about now. However I have no clue what would cause such a thing. If I think of anything that could have, I'll make another post.
    have you (or anyone ) made a prog with the nice looking GUI? (like the 1st picture, the one run from IDLE)
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2005
    Posts
    4
    Rep Power
    0
    Well, I found out what the problem is

    You have to put the .manifest file in the working dir. of your program and rename it to 'exename'.manifest

    where 'exename' = pspimage.exe (in my case)
    so the filename would be: pspimage.exe.manifest

    Happy Pythonprogging

IMN logo majestic logo threadwatch logo seochat tools logo