#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    5
    Rep Power
    0

    Can't find the sympy module


    This question is far more vague than I'd like it to be, because I honestly do not understand what I'm doing wrong. I need the sympy module for an application (fluid modelling using Sailfish) and by now I think I've tried at least three different ways of downloading and installing it. Including the macport installation specified in the instruction book. For the sake of version compatibility, the particular python version I'm using is 2.7.5. However, all I get when trying to import it is the classical Module not found. So yea, in essence:

    I want the sympy module, as far as I can tell I've chosen the proper version, downloaded and unpacked it and still seem unable to use it. I can't recall doing else in particular with, for example, pygame when I started using that. So. Um. Is there perhaps anyone here who might offer some thoughts on what I'm missing?
  2. #2
  3. Contributing User
    Devshed Demi-God (4500 - 4999 posts)

    Join Date
    Aug 2011
    Posts
    4,995
    Rep Power
    481
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    5
    Rep Power
    0
    Well, yes, obviously. Provided that I'm not managing to completely miss something - shouldn't it be enough to run the Fink installation? From what I can tell the provided tests check out without any errors or warnings. In fact, I've managed to set up an even more awesome problem:

    If I go the traditional route of opening IDLE, creating a new script file and running the program from there, it finds numpy but not sympy. More specifically it complains about sympy.core, but I tried an import of sympy itself, just to confirm that it can't find that either.
    If I try to run the script from terminal (python2.7 filename.py) it can't find numpy, while sympy seems to be A-OK.

    Fink, macport, download directly and unpack, python setup.py install... I wouldn't be surprised if there's a really simple answer, but at the moment I'm frankly reduced to staring at the screen and nigh begging for help, or at least mercy.
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2013
    Posts
    6
    Rep Power
    0
    Originally Posted by Devam
    This question is far more vague than I'd like it to be, because I honestly do not understand what I'm doing wrong. I need the sympy module for an application (fluid modelling using Sailfish) and by now I think I've tried at least three different ways of downloading and installing it. Including the macport installation specified in the instruction book. For the sake of version compatibility, the particular python version I'm using is 2.7.5. However, all I get when trying to import it is the classical Module not found. So yea, in essence:

    I want the sympy module, as far as I can tell I've chosen the proper version, downloaded and unpacked it and still seem unable to use it. I can't recall doing else in particular with, for example, pygame when I started using that. So. Um. Is there perhaps anyone here who might offer some thoughts on what I'm missing?
    Did you install with the tarball and then python setup.py install?

IMN logo majestic logo threadwatch logo seochat tools logo