Page 1 of 2 12 Last
  • Jump to page:
    #1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1

    redirect url with tag


    Hello
    I have many error 404 for old path tag.. It's possibile to make regex in .htaccess from

    old URL
    https://www.mysite.it/?tag=/Freemake+video+Converter

    to new URL
    https://www.mysite.it/tag/Freemake-video-Converter/

    Thank you very much
    Fabrizio
  2. #2
  3. Impoverished Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,869
    Rep Power
    9646
    Possible, but not easy because you want to change the +s into -s.

    How hard would it be to change in the application's own code? Or can you leave it with spaces?
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1
    it's a redirect from the old site and I can not change the old url...
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1
    Search Google signals me this URL, and I have also this URL in old my site in localhost... CMS was blogengine.net..
  8. #5
  9. Impoverished Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,869
    Rep Power
    9646
    Does it even support /tag? There's no documentation for any of this. And what little code I'm reading through so far has significant issues. Not impressed.

    But this is all .NET stuff. Are you sure you're using BlogEngine.NET? With Apache?

    edit: Oh wait, it "was" that. What you were running before doesn't really matter. What are you running now?
    Last edited by requinix; March 10th, 2018 at 07:40 AM.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1
    I migrated from blogengine.net to wordpress (server before was windows server) ... Now I'm using Wordpress with Apache

    and paths tag now are so: https://www.mysite.it/tag/Freemake-Video-Converter/

    Today I see on Search Console 1.120 error 404 with this path: https://www.mysite/?tag=/Freemake+Video+Converter/ that was old url of mysite in blogengine.net

    to correct these errors I should not be redirected?
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1
    this is an example: https://www.mysite/?tag=/Freemake+Video+Converter/ error 404 are different but all with the same format ?tag= with +
  14. #8
  15. Impoverished Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,869
    Rep Power
    9646
    Ah, WordPress.

    Can you check whether /tag/Freemake+Video+Converter/ and /tag/Freemake%20Video%20Converter/ work?
  16. #9
  17. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1
    Where I must to Check? In wordpress don't work.. both

    If i try this https://www.mysite.it/?tag=/Freemake...eo%20Converter in blogengine.net in locahost works
  18. #10
  19. Impoverished Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,869
    Rep Power
    9646
    Yes, I know the old URL works in the old system. There's no question about that.

    What I want to know is whether going to /tag/Freemake+Video+Converter/ and /tag/Freemake%20Video%20Converter/ in the new WP site works. In other words, if WP is okay with there being spaces in the tag names or whether they really do have to be hyphens.
  20. #11
  21. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1
    Don't work, I tried..
  22. #12
  23. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1
    WP want hyphens
  24. #13
  25. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1
    Without and with your solution, in WP I have Error 404
  26. #14
  27. Impoverished Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,869
    Rep Power
    9646
    I haven't given you any "solution" so I don't know what you tried.

    What are the contents of your current index.php?
  28. #15
  29. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2018
    Posts
    65
    Rep Power
    1
    PHP Code:
    <?php

    get_header
    (); ?>

        <?php do_action'mag_before_body_content' ); ?>

        <div id="primary">
            <div id="content" class="clearfix">

                <?php if ( have_posts() ) : ?>

                    <?php while ( have_posts() ) : the_post(); ?>

                        <?php get_template_part'content''' ); ?>

                    <?php endwhile; ?>

                    <?php get_template_part'navigation''none' ); ?>

                <?php else : ?>

                    <?php get_template_part'no-results''none' ); ?>

                <?php endif; ?>

            </div><!-- #content -->
        </div><!-- #primary -->

        <?php mag_sidebar_select(); ?>

        <?php do_action'mag_after_body_content' ); ?>

    <?php get_footer(); ?>
Page 1 of 2 12 Last
  • Jump to page:

IMN logo majestic logo threadwatch logo seochat tools logo