#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2012
    Location
    India
    Posts
    14
    Rep Power
    0

    Error with MySQL and Rails 3.1.0


    I get this error durring the instalation of an application Rails:

    Gem files will remain installed in /home/mark/.bundler/tmp/28288/gems/mysql2-0.2.17 for inspection. Results logged to /home/mark/.bundler/tmp/28288/gems/mysql2-0.2.17/ext/mysql2/gem_make.out An error occured while installing mysql2 (0.2.17), and Bundler cannot continue. Make sure that gem install mysql2 -v '0.2.17' succeeds before bundling.

    Can you help me to resolved the problem, please.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2005
    Posts
    112
    Rep Power
    10
    Hi,

    Most probably the native build is failing for mysql2 gem. Try executing the gem install command manually and check if it complains for build error:

    gem install mysql2 -v '0.2.17'

    Also, ensure that you have installed dev libraries which are required for building native extension for mysql.
    @ PresentSoft Technologies Pvt. Ltd., a software development firm in Goa - India, we develop scalable applications using on Ruby on Rails and Android.

    My blog @ AnayKamat.com

IMN logo majestic logo threadwatch logo seochat tools logo