Thread: Rails ?

    #1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    184
    Rep Power
    29

    Question Rails ?


    I am trying to use Ruby On Rails and I am having a bit of a problem. I installed ruby on rails on my Windows XP machine. Then I created a hello project like

    rails hello

    this works fine when I use my web browser to go to http://localhost:3000 and I get the familiar success page.

    then I create a controller like

    ruby script/generate controller Hello index. Now if I again use my web browser to go to http://localhost:3000/hello I get an error message that says 'We're sorry, but something went wrong'.

    Anyone have any idea what I am doing wrong. I followed the same procedure from two different books, but it does not seem to work.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    184
    Rep Power
    29
    Originally Posted by Z.K.
    I am trying to use Ruby On Rails and I am having a bit of a problem. I installed ruby on rails on my Windows XP machine. Then I created a hello project like

    rails hello

    this works fine when I use my web browser to go to http://localhost:3000 and I get the familiar success page.

    then I create a controller like

    ruby script/generate controller Hello index. Now if I again use my web browser to go to http://localhost:3000/hello I get an error message that says 'We're sorry, but something went wrong'.

    Anyone have any idea what I am doing wrong. I followed the same procedure from two different books, but it does not seem to work.
    I just tried this same routine on a linux box and it worked fine. So, apparently, I have a problem with my Ruby On Rails setup on my Windows machine.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    184
    Rep Power
    29
    Never mind, I figured it out. I had to install sqlite3 manually.

IMN logo majestic logo threadwatch logo seochat tools logo