#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2008
    Location
    venezuela
    Posts
    3
    Rep Power
    0

    Question Ruby Deprecated And Outdated???


    ok ppl, im having a problem here, im using windows xp and ruby 1.8.6 with rails 2.1.1 and radrails 0.7.2 when i want to use the generator for a scaffold it says:

    Gem::SourceIndex#search support for Regexp patterns is deprecated
    C:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/rails_generator/lookup.rb:211:in `each' is outdated

    i dont know what to do, any help here?
  2. #2
  3. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,643
    Rep Power
    4248
    First, this is a warning, not an error. It is just warning you that something is using code that is being deprecated and may not be supported in the future. Sounds like one of the gems that you have installed is outdated. Please run "gem -v" from the command line and tell us what version of gem are you using.

    Also have you tried updating all your installed gems. Maybe that might fix it.
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo

IMN logo majestic logo threadwatch logo seochat tools logo