#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2006
    Posts
    2
    Rep Power
    0

    Configuration problem.... plz help me !!


    i have install ruby 1.8.5 (2006-08-25) [i386-mswin32] and also install rails..... according to tutorial http://allaboutruby.wordpress.com/2006/01/09/installing-rails-on-windows-step-by-step-tutorial/

    and according to 'Rails in action' section of the tutorial when I configure 'database.yml' file like ,

    development:
    adapter: mysql
    database: firstproject
    username: root
    password: password
    host: localhost

    and try to start the server by command "ruby script/server" the following error occure, how I will solve it,

    => Booting WEBrick...
    F:/Ruby/installation/ruby/lib/ruby/1.8/yaml.rb:133:in `load': syntax error on li
    ne 17, col 2: ` host:localhost' (ArgumentError)
    from F:/Ruby/installation/ruby/lib/ruby/1.8/yaml.rb:133:in `load'
    from F:/Ruby/installation/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/in
    itializer.rb:459:in `database_configuration'
    from F:/Ruby/installation/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/in
    itializer.rb:181:in `initialize_database'
    from F:/Ruby/installation/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/in
    itializer.rb:84:in `process'
    from F:/Ruby/installation/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/in
    itializer.rb:42:in `send'
    from F:/Ruby/installation/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/in
    itializer.rb:42:in `run'
    from ./script/../config/../config/environment.rb:13
    from F:/Ruby/installation/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_re
    quire.rb:27:in `gem_original_require'
    ... 7 levels...
    from F:/Ruby/installation/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_re
    quire.rb:27:in `gem_original_require'
    from F:/Ruby/installation/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_re
    quire.rb:27:in `require'
    from F:/Ruby/installation/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.
    1/lib/active_support/dependencies.rb:147:in `require'
    from script/server:3

    please any one help me !!!

    thank you ....
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2006
    Posts
    2
    Rep Power
    0
    yes ,it is nothing but version problem, after using ruby 1.8.2 (2004-12-25) [i386-mswin32] it working......

IMN logo majestic logo threadwatch logo seochat tools logo