#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2012
    Location
    Virginia
    Posts
    46
    Rep Power
    3

    Problems setting up ruby on rails enviroment.


    Any suggestions this occurs when I try to save the keys
    using the following command, I am using a cygwin unique like environment. "$ heroku keys:add" causes the following:
    Code:
    /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/bundler/resol                     ver.rb:287:in `resolve': Could not find gem 'sqlite3 (= 1.3.1) ruby' in the gems                      available on this machine. (Bundler::GemNotFound)
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/resolver.rb:161:in `start'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/resolver.rb:128:in `block in resolve'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/resolver.rb:127:in `catch'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/resolver.rb:127:in `resolve'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/definition.rb:192:in `resolve'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/definition.rb:127:in `specs'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/environment.rb:27:in `specs'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/rubygems-bundler-1                     .0.2/lib/rubygems-bundler/noexec.rb:41:in `candidate?'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/rubygems-bundler-1                     .0.2/lib/rubygems-bundler/noexec.rb:60:in `setup'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/rubygems-bundler-1                     .0.2/lib/rubygems-bundler/noexec.rb:75:in `<top (required)>'
            from /home/Doug/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rub                     ygems/custom_require.rb:60:in `require'
            from /home/Doug/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rub                     ygems/custom_require.rb:60:in `rescue in require'
            from /home/Doug/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rub                     ygems/custom_require.rb:35:in `require'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:9:in `                     <main>'
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2012
    Location
    Virginia
    Posts
    46
    Rep Power
    3
    Originally Posted by TaronDcross
    Any suggestions this occurs when I try to save the keys
    using the following command, I am using a cygwin unique like environment. "$ heroku keys:add" causes the following:
    Code:
    /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/bundler/resol                     ver.rb:287:in `resolve': Could not find gem 'sqlite3 (= 1.3.1) ruby' in the gems                      available on this machine. (Bundler::GemNotFound)
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/resolver.rb:161:in `start'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/resolver.rb:128:in `block in resolve'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/resolver.rb:127:in `catch'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/resolver.rb:127:in `resolve'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/definition.rb:192:in `resolve'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/definition.rb:127:in `specs'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.1.3/lib/                     bundler/environment.rb:27:in `specs'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/rubygems-bundler-1                     .0.2/lib/rubygems-bundler/noexec.rb:41:in `candidate?'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/rubygems-bundler-1                     .0.2/lib/rubygems-bundler/noexec.rb:60:in `setup'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194@global/gems/rubygems-bundler-1                     .0.2/lib/rubygems-bundler/noexec.rb:75:in `<top (required)>'
            from /home/Doug/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rub                     ygems/custom_require.rb:60:in `require'
            from /home/Doug/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rub                     ygems/custom_require.rb:60:in `rescue in require'
            from /home/Doug/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rub                     ygems/custom_require.rb:35:in `require'
            from /home/Doug/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:9:in `                     <main>'
    A friend asked me if my rvm had installed told me to use the command "rvm gem install heroku" to try to fix the problem, this does not seem to work. I am still getting the same output identically. While the command itself works but flags a deprecated it does not solve the problem for "heroku login".


    Edit:3:43pm
    http://benscheirman.com/2009/06/getting-started-with-heroku-on-windows

    Tried, this is old and does not work anymore anyone know what the updates are to make it work?

    I've also tried uninstalling heroku gem and reinstalling it, so far this has not fixed issues with it and the sqlite3 gem when I've also tried that with as well that happens to be throwing out the error.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2012
    Location
    Virginia
    Posts
    46
    Rep Power
    3

    Solution found


    The end problem for the following is for whatever reason heroku doesn't like a specific sqlite3 gem version. To solve this I had to go to use the following command "vim gemfile" to open up my gemfile and remove the version requirements set on the sqlite3 gem since heroku will not be able to find the particular gem sqlite3 for whatever reason. Anyone know why there is a conflict with about any version I pick for sqlite3 I'd love to know. Maybe there's a version I do not know of that heroku is dependent on. I hope this helps someone else out later.

IMN logo majestic logo threadwatch logo seochat tools logo