Hi

We had problems with customers using pre IE 5.5 and Mac users. The mod SSL site explains that this is due to a bug in IE and related to openssl.

Anyway we came across http://www.apache-ssl.com installed in place of apache and mod_SSL and its cured all our problems. The installation was a littler harder and took some refining but the author responds to e-mails within a day!

So if you having the same problems I would recommend this option.

Regards
Darren