#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2003
    Posts
    1
    Rep Power
    0

    NT Authent problems using Robocopy via ASP between servers


    Issue is this: How to succesfully run a .bat file that runs Robocopy.exe to copy files from one web server to another web server by calling the Dynu.Exec com component though ASP.

    Looking into the info regarding IIS, the problem would appear to be with IIS executing .dll files(in this case Dynu.Exec which, in turn, runs the Robocopy .bat file) under the IUSR_machinename account, so when Robocopy reaches the destionation machine it has no account with which to authenticate with and is therefore denied.

    Note: If I terminal service onto the first machine and run the .bat file at the command line it works fine (I have admin rights on both machines), BUT if I use Dynu to run the .bat file from an asp page I get an access denied permissions error when Robocopy tries to write files to the destination machine.

    I've tried creating a local user on the destination machine with the same details as the IUSR_machinename account on the orgininating machine but still no dice.
    Also tried several methods of making the Dynu.Exec object run under a different username (domain admin etc) by both making changes to the .bat file and also making changes in the registry to 'runas' but that didnt work either!

    Ideas please!!!
  2. #2
  3. Full Access
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Jun 2000
    Location
    London, UK
    Posts
    2,019
    Rep Power
    17
    This has no bearing on Security whatsoever.
    Alex
    (http://www.alex-greg.com)

IMN logo majestic logo threadwatch logo seochat tools logo