#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2017
    Posts
    7
    Rep Power
    0

    Help with Admin password from curcfg.xml


    I have a huawei E5172s-920 router that requres admin login in order to access software features
    like adding APN, uploading device software and so on. After logging in with the details
    username:user and password:user and fiddling with the software interface for hours I was
    able to save the diagnostics file to my PC. A file named curcfg.xml inside diagnose.rar
    appears to be containing the admin password in an encrypted form. I would like somebody to
    help with decrypting the password for the admin account. Thanks
    Sorry, could not figure out how to upload files so I decided to paste everything here.
    xml Code:
    <?xml version="1.0" ?>
    <InternetGatewayDeviceConfig>
    	<InternetGatewayDevice>
    		<DeviceConfig PersistentData="" RestoreFlag="0" />
    		<DeviceInfo ProvisioningCode="">
    			<X_PortalManagement Enable="0" PortalUrl-Computer="" PortalUrl-STB="" PortalUrl-Phone="" />
    			<X_ServiceManage TelnetEnable="0" TelnetPort="23" />
    			<X_Antenna status="1" status2="1" autoenable="0" />
    		</DeviceInfo>
    		<ManagementServer EnableCWMP="1" URL="https://spectranetacs.spectranet.com.ng:7547" Username="" Password="" PeriodicInformEnable="1" PeriodicInformInterval="7200" ConnectionRequestUsername="acs" ConnectionRequestPassword="GswfQSFdRrm=" X_SSLCertEnable="0" X_ConnReqPort="8081" />
    		<Time Enable="1" NTPServer1="clock.fmt.he.net" NTPServer2="clock.nyc.he.net" NTPServer3="" NTPServer4="" NTPServer5="" LocalTimeZoneName="GMT-01:00DST-02:00:00,M3.5.0/02:00:00,M10.5.0/03:00:00" X_Label="29" ConfigType="2" MannualTime="" DaylightSavingEnable="1" />
    		<UserInterface>
    			<X_Web Timeout="5" WebProtectionState="0" ProtectionPages="0,0,0,1," RandomString="" DomainName="homerouter.cpe" TmpWebProtectionState="0">
    				<MailConfig SMTPServer="" MailSenderId="" MailSenderpassword="" />
    				<UserInfo NumberOfInstances="2">
    					<UserInfoInstance InstanceID="1" Username="admin" Userpassword="yzsxFbrb5RCqPM99Ev+dcZkcetgqkr67KtpXmEt5YJoBoUKexSr1FR==" Pwdchanged="0" RemindChangePwdEnable="1" Email="" TmpEmail="" />
    					<UserInfoInstance InstanceID="2" Username="user" Userpassword="f3nGyuud1GOisBNXC7rPJAlW1yQgE7sd/XAB1WiPVF66OFNNjCkVcw==" Pwdchanged="0" RemindChangePwdEnable="0" Email="" TmpEmail="" />
    				</UserInfo>
    				<HttpUpg UpdateURL="update-africa.huaweidevice.com" UpdatePort="80" CheckNewVer="" SubURL="/africa" PeriodicTime="168" DisplayPeriodicTimeFlag="0" />
    			</X_Web>
    			<X_Cli>
    				<UserInfo NumberOfInstances="2">
    					<UserInfoInstance InstanceID="1" Username="admin" Userpassword="yzsxFbrb5RDd8DocU3YGdG0JKWvZvsV4GrfmYAXL6t1LxDziSi7Xfs==" Userlevel="0" />
    					<UserInfoInstance InstanceID="2" Username="user" Userpassword="yzsxFbrb5RCgAS896Vnla5jWaRN4Uhg6+KjmwSQ/OZVLYcC7EeIVZz==" Userlevel="1" />
    				</UserInfo>
    			</X_Cli>
    		</UserInterface>
    		<X_SyslogConfig Enable="1" Level="Debug" DisplayLevel="Informational" LogServerEnable="0" MainServer="" MainServerPort="514" MinorServer="" MinorServerPort="514" />
    		<Layer3Forwarding X_AutoDefaultGatewayEnable="0" X_DefaultGatewayIPAddress="" DefaultConnectionService="">
    		</Layer3Forwarding>
    		<LANDevice NumberOfInstances="1">
    			<LANDeviceInstance InstanceID="1" X_WLANEnable="1">
    				<LANHostConfigManagement DHCPServerEnable="1" DHCPServerConfigurable="1" MinAddress="192.168.1.1" MaxAddress="192.168.1.254" ReservedAddresses="" DNSServers="" DomainName="" IPRouters="" DHCPLeaseTime="86400" UseAllocatedWAN="" AssociatedConnection="" PassthroughLease="60" PassthroughMACAddress="">
    					<X_DHCPv6 DHCPServerEnable="1" UseAllocatedWAN="UseAllocatedSubnet" AssociatedConnection="InternetGatewayDevice.WANDevice.3.WANConnectionDevice.1.WANIPConnection.1" Prefix="3001:2::" PrefixLength="64" Preferredlifetime="3600" Validlifetime="7200" DNSServer="" DomainName="" />
    					<X_SLAAC RouterAdvertisementEnable="1" UseAllocatedWAN="UseAllocatedSubnet" AssociatedConnection="InternetGatewayDevice.WANDevice.3.WANConnectionDevice.1.WANIPConnection.1" Prefix="3001:2::" PrefixLength="64" Preferredlifetime="3600" Validlifetime="7200" />
    					<DHCPConditionalServingPool NumberOfInstances="4">
    						<ObjExtention MaxInstanceNum="4" />
    						<DHCPConditionalServingPoolInstance InstanceID="1" Enable="1" MinAddress="0.0.0.0" MaxAddress="0.0.0.0" VendorClassID="STB" X_DeviveDhcpRelay="0" />
    						<DHCPConditionalServingPoolInstance InstanceID="2" Enable="1" MinAddress="0.0.0.0" MaxAddress="0.0.0.0" VendorClassID="Phone" X_DeviveDhcpRelay="0" />
    						<DHCPConditionalServingPoolInstance InstanceID="3" Enable="1" MinAddress="0.0.0.0" MaxAddress="0.0.0.0" VendorClassID="Camera" X_DeviveDhcpRelay="0" />
    						<DHCPConditionalServingPoolInstance InstanceID="4" Enable="1" MinAddress="0.0.0.0" MaxAddress="0.0.0.0" VendorClassID="windows client" X_DeviveDhcpRelay="0" />
    					</DHCPConditionalServingPool>
    					<IPInterface NumberOfInstances="1">
    						<IPInterfaceInstance InstanceID="1" Enable="0" IPInterfaceIPAddress="192.168.1.1" IPInterfaceSubnetMask="255.255.255.0" IPInterfaceAddressingType="DHCP" X_RouteProtocolRx="Off" X_RIPOperation="Active" X_Pre_RouteProtocol="RIPv1/v2" />
    					</IPInterface>
    				</LANHostConfigManagement>
    				<LANEthernetInterfaceConfig NumberOfInstances="4">
    					<ObjExtention MaxInstanceNum="4" />
    					<LANEthernetInterfaceConfigInstance InstanceID="1" Enable="1">
    					</LANEthernetInterfaceConfigInstance>
    					<LANEthernetInterfaceConfigInstance InstanceID="2" Enable="1">
    					</LANEthernetInterfaceConfigInstance>
    					<LANEthernetInterfaceConfigInstance InstanceID="3" Enable="1">
    					</LANEthernetInterfaceConfigInstance>
    					<LANEthernetInterfaceConfigInstance InstanceID="4" Enable="1">
    					</LANEthernetInterfaceConfigInstance>
    				</LANEthernetInterfaceConfig>
    				<WLANConfiguration NumberOfInstances="4">
    					<WLANConfigurationInstance InstanceID="1" SSIDAdvertisementEnabled="1" Enable="1" MaxBitRate="Auto" Channel="6" AutoChannelEnable="1" RegulatoryDomain="CN" SSID="Spectranet-LTE" BeaconType="WPAand11i" MACAddressControlEnabled="1" WEPKeyIndex="1" WEPEncryptionLevel="104-bit" BasicEncryptionModes="WEPEncryption" BasicAuthenticationMode="SharedAuthentication" WPAEncryptionModes="TKIPandAESEncryption" WPAAuthenticationMode="PSKAuthentication" IEEE11iEncryptionModes="TKIPandAESEncryption" IEEE11iAuthenticationMode="PSKAuthentication" WMMEnable="0" X_WlanStandard="b/g/n" TransmitPower="100" X_WDSEnable="0" X_WDSEncryptionModes="None" X_WDSKey="" X_WDSMode="Repeater" X_LAZYWDS="2" X_MixedEncryptionModes="TKIPandAESEncryption" X_MixedAuthenticationMode="PSKAuthentication" X_AssociateDeviceNum="10" X_WlanMacFilterpolicy="0" X_WlanStaWakeEnable="0" X_WlanIsolateControl="0" X_Wlan11NBWControl="20">
    						<Stats/>
    						<WPS Enable="0" X_WPSMode="client-pin" DevicePassword="00764995" />
    						<WEPKey NumberOfInstances="4">
    							<WEPKeyInstance InstanceID="1" WEPKey="cXRhckZSNFg6796jIuZKTYSuOkXYqIwXkA==" />
    							<WEPKeyInstance InstanceID="2" WEPKey="cXRhckZSNFg6DMQnhiQq84P+Rz/u3/Kxfg==" />
    							<WEPKeyInstance InstanceID="3" WEPKey="cXRhckZSNFg6Qfp3WS4uk3TL+tNgabXvCw==" />
    							<WEPKeyInstance InstanceID="4" WEPKey="cXRhckZSNFg6I7c3+llcH/keXtn3CzCLLQ==" />
    						</WEPKey>
    						<PreSharedKey NumberOfInstances="1">
    							<PreSharedKeyInstance InstanceID="1" PreSharedKey="YTV5dGlmQ3c6OZQfo68O2M98D0W7T3xSsg==" KeyPassphrase="abcdedfg" />
    						</PreSharedKey>
    						<X_BridgeRestriction NumberOfInstances="4">
    							<X_BridgeRestrictionInstance InstanceID="1" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="2" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="3" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="4" X_WlanBridgeMacAddress="" />
    						</X_BridgeRestriction>
    					</WLANConfigurationInstance>
    					<WLANConfigurationInstance InstanceID="2" SSIDAdvertisementEnabled="1" Enable="0" MaxBitRate="Auto" Channel="6" AutoChannelEnable="1" RegulatoryDomain="CN" SSID="HUAWEI-E5172-6602S1" BeaconType="WPAand11i" MACAddressControlEnabled="1" WEPKeyIndex="1" WEPEncryptionLevel="104-bit" BasicEncryptionModes="WEPEncryption" BasicAuthenticationMode="SharedAuthentication" WPAEncryptionModes="TKIPandAESEncryption" WPAAuthenticationMode="PSKAuthentication" IEEE11iEncryptionModes="TKIPandAESEncryption" IEEE11iAuthenticationMode="PSKAuthentication" WMMEnable="1" X_WlanStandard="b/g/n" TransmitPower="100" X_WDSEnable="0" X_WDSEncryptionModes="None" X_WDSKey="" X_WDSMode="Repeater" X_LAZYWDS="2" X_MixedEncryptionModes="TKIPandAESEncryption" X_MixedAuthenticationMode="PSKAuthentication" X_AssociateDeviceNum="10" X_WlanMacFilterpolicy="0" X_WlanStaWakeEnable="0" X_WlanIsolateControl="0" X_Wlan11NBWControl="20">
    						<Stats/>
    						<WPS Enable="0" X_WPSMode="client-pin" DevicePassword="15211347" />
    						<WEPKey NumberOfInstances="4">
    							<WEPKeyInstance InstanceID="1" WEPKey="cXRhckZSNFg6796jIuZKTYSuOkXYqIwXkA==" />
    							<WEPKeyInstance InstanceID="2" WEPKey="cXRhckZSNFg6DMQnhiQq84P+Rz/u3/Kxfg==" />
    							<WEPKeyInstance InstanceID="3" WEPKey="cXRhckZSNFg6Qfp3WS4uk3TL+tNgabXvCw==" />
    							<WEPKeyInstance InstanceID="4" WEPKey="cXRhckZSNFg6I7c3+llcH/keXtn3CzCLLQ==" />
    						</WEPKey>
    						<PreSharedKey NumberOfInstances="1">
    							<PreSharedKeyInstance InstanceID="1" PreSharedKey="YTV5dGlmQ3c6WvB/45BGC9BZP2Z8tcOT/w==" KeyPassphrase="abcdedfg" />
    						</PreSharedKey>
    						<X_BridgeRestriction NumberOfInstances="4">
    							<X_BridgeRestrictionInstance InstanceID="1" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="2" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="3" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="4" X_WlanBridgeMacAddress="" />
    						</X_BridgeRestriction>
    					</WLANConfigurationInstance>
    					<WLANConfigurationInstance InstanceID="3" SSIDAdvertisementEnabled="1" Enable="0" MaxBitRate="Auto" Channel="6" AutoChannelEnable="1" RegulatoryDomain="CN" SSID="HUAWEI-E5172-6602S2" BeaconType="WPAand11i" MACAddressControlEnabled="1" WEPKeyIndex="1" WEPEncryptionLevel="104-bit" BasicEncryptionModes="WEPEncryption" BasicAuthenticationMode="SharedAuthentication" WPAEncryptionModes="TKIPandAESEncryption" WPAAuthenticationMode="PSKAuthentication" IEEE11iEncryptionModes="TKIPandAESEncryption" IEEE11iAuthenticationMode="PSKAuthentication" WMMEnable="1" X_WlanStandard="b/g/n" TransmitPower="100" X_WDSEnable="0" X_WDSEncryptionModes="None" X_WDSKey="" X_WDSMode="Repeater" X_LAZYWDS="2" X_MixedEncryptionModes="TKIPandAESEncryption" X_MixedAuthenticationMode="PSKAuthentication" X_AssociateDeviceNum="10" X_WlanMacFilterpolicy="0" X_WlanStaWakeEnable="0" X_WlanIsolateControl="0" X_Wlan11NBWControl="20">
    						<Stats/>
    						<WPS Enable="0" X_WPSMode="client-pin" DevicePassword="15211347" />
    						<WEPKey NumberOfInstances="4">
    							<WEPKeyInstance InstanceID="1" WEPKey="cXRhckZSNFg6796jIuZKTYSuOkXYqIwXkA==" />
    							<WEPKeyInstance InstanceID="2" WEPKey="cXRhckZSNFg6DMQnhiQq84P+Rz/u3/Kxfg==" />
    							<WEPKeyInstance InstanceID="3" WEPKey="cXRhckZSNFg6Qfp3WS4uk3TL+tNgabXvCw==" />
    							<WEPKeyInstance InstanceID="4" WEPKey="cXRhckZSNFg6I7c3+llcH/keXtn3CzCLLQ==" />
    						</WEPKey>
    						<PreSharedKey NumberOfInstances="1">
    							<PreSharedKeyInstance InstanceID="1" PreSharedKey="YTV5dGlmQ3c6YTZqzZfOxDPqP35OQUz2gQ==" KeyPassphrase="abcdedfg" />
    						</PreSharedKey>
    						<X_BridgeRestriction NumberOfInstances="4">
    							<X_BridgeRestrictionInstance InstanceID="1" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="2" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="3" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="4" X_WlanBridgeMacAddress="" />
    						</X_BridgeRestriction>
    					</WLANConfigurationInstance>
    					<WLANConfigurationInstance InstanceID="4" SSIDAdvertisementEnabled="1" Enable="0" MaxBitRate="Auto" Channel="6" AutoChannelEnable="1" RegulatoryDomain="CN" SSID="HUAWEI-E5172-6602S3" BeaconType="WPAand11i" MACAddressControlEnabled="1" WEPKeyIndex="1" WEPEncryptionLevel="104-bit" BasicEncryptionModes="WEPEncryption" BasicAuthenticationMode="SharedAuthentication" WPAEncryptionModes="TKIPandAESEncryption" WPAAuthenticationMode="PSKAuthentication" IEEE11iEncryptionModes="TKIPandAESEncryption" IEEE11iAuthenticationMode="PSKAuthentication" WMMEnable="1" X_WlanStandard="b/g/n" TransmitPower="100" X_WDSEnable="0" X_WDSEncryptionModes="None" X_WDSKey="" X_WDSMode="Repeater" X_LAZYWDS="2" X_MixedEncryptionModes="TKIPandAESEncryption" X_MixedAuthenticationMode="PSKAuthentication" X_AssociateDeviceNum="10" X_WlanMacFilterpolicy="0" X_WlanStaWakeEnable="0" X_WlanIsolateControl="0" X_Wlan11NBWControl="20">
    						<Stats/>
    						<WPS Enable="0" X_WPSMode="client-pin" DevicePassword="15211347" />
    						<WEPKey NumberOfInstances="4">
    							<WEPKeyInstance InstanceID="1" WEPKey="cXRhckZSNFg6796jIuZKTYSuOkXYqIwXkA==" />
    							<WEPKeyInstance InstanceID="2" WEPKey="cXRhckZSNFg6DMQnhiQq84P+Rz/u3/Kxfg==" />
    							<WEPKeyInstance InstanceID="3" WEPKey="cXRhckZSNFg6Qfp3WS4uk3TL+tNgabXvCw==" />
    							<WEPKeyInstance InstanceID="4" WEPKey="cXRhckZSNFg6I7c3+llcH/keXtn3CzCLLQ==" />
    						</WEPKey>
    						<PreSharedKey NumberOfInstances="1">
    							<PreSharedKeyInstance InstanceID="1" PreSharedKey="YTV5dGlmQ3c6ZODMqhMrUqjIcFGhYApiOg==" KeyPassphrase="abcdedfg" />
    						</PreSharedKey>
    						<X_BridgeRestriction NumberOfInstances="4">
    							<X_BridgeRestrictionInstance InstanceID="1" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="2" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="3" X_WlanBridgeMacAddress="" />
    							<X_BridgeRestrictionInstance InstanceID="4" X_WlanBridgeMacAddress="" />
    						</X_BridgeRestriction>
    					</WLANConfigurationInstance>
    				</WLANConfiguration>
    Last edited by requinix; April 25th, 2017 at 02:39 AM. Reason: [highlight] tags and formatting
  2. #2
  3. Lazy Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,382
    Rep Power
    9645
    Wouldn't it be better to simply reset the router? Then you can reconfigure it as you want.

    And if you're able to log in, why not change the password there?
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2017
    Posts
    7
    Rep Power
    0
    It is a branded 4G router. It has been unlocked to accept other network sim cards. The problem now is I can't change the APN without admin access.
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Location
    Nebraska, USA
    Posts
    937
    Rep Power
    279
    since the user acct login info is user/user, have you tried admin/admin for the admin acct login? How to Login to the Huawei E5172s-920
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2017
    Posts
    7
    Rep Power
    0
    Yes i've tried several combinations seggested on many websites but none of them worked.
  10. #6
  11. Lazy Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,382
    Rep Power
    9645
    Reset the router, download the configuration XML again, put the passwords from the new config into a copy of the old one, and upload the new configuration (assuming that's possible).
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2017
    Posts
    7
    Rep Power
    0
    Not too sure how I did it again but I suspect the configuration XML was downloaded when I ran dignostics from the web interface. I forgot to mention that telnet has been disabled on this router. Even when I manage to enable it using telnetEnable program it disables itself after a few seconds leaving me with no time to log in and do any thing meaningful. This appears to be what Am looking for but it needs to be decrypted first:
    <UserInfo NumberOfInstances="2">
    <UserInfoInstance InstanceID="1" Username="admin" Userpassword="yzsxFbrb5RDd8DocU3YGdG0JKWvZvsV4GrfmYAXL6t1LxDziSi7Xfs==" Userlevel="0" />
    <UserInfoInstance InstanceID="2" Username="user" Userpassword="yzsxFbrb5RCgAS896Vnla5jWaRN4Uhg6+KjmwSQ/OZVLYcC7EeIVZz==" Userlevel="1" />
    </UserInfo>
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2017
    Posts
    7
    Rep Power
    0
    Still looking for a solution. Any so far?
  16. #9
  17. Lazy Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,382
    Rep Power
    9645
  18. #10
  19. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2017
    Posts
    7
    Rep Power
    0
    How do I upload configuration xml file to the router?
  20. #11
  21. Lazy Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,382
    Rep Power
    9645
    I don't know. If you can download configuration then it's likely you can upload it too - probably on the same page where you download from.
  22. #12
  23. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2017
    Posts
    7
    Rep Power
    0
    How do I upload on that same page. There is no provision for doing that on the web page from where I downloaded the file or can you pls guide me on how to upload the file.
  24. #13
  25. Lazy Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,382
    Rep Power
    9645
    I don't know. I don't have that router, I've never seen or used that router. Find the user's manual and see what it says.

IMN logo majestic logo threadwatch logo seochat tools logo