#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2011
    Posts
    6
    Rep Power
    0

    Problem in php installation..


    hi am senthil,

    am trying to install PHP in my solaris 10 x86 ...
    i installed oracle,apache,tomcat,mysql ..
    the only thing am missing is PHP..

    i tried to install php using ./configure ..

    my ./configure command..

    ./configure \
    --with-apxs=/usr/apache/bin/apxs \
    --with-libxml-dir=/usr/include/libxml2/libxml \
    --with-config-file-path=/etc/apache2 \
    --with-mysql=shared,/opt/mysql/mysql \
    --with-mysqli=shared,/opt/mysql/mysql/bin/mysql_config \
    --with-iconv-dir=/usr/local \
    --with-xpm-dir=/usr/share/gnome/gperfmeter --with-gd --with-jpeg-dir=/usr/sfw/lib/gimp/2.0/plug-ins \
    --with-png-dir=/usr/sfw/lib/gimp/2.0/plug-ins/ --with-zlib --enable-mbstring


    first everthing runs well ..
    finally it showed me ..

    "Thanking for using PHP"
    it didn throw me any error..
    when i typed
    make command..

    it showed me some messages and
    finally i got this error..

    Undefined first referenced
    symbol in file
    libiconv_close ext/gd/libgd/.libs/gdkanji.o
    libiconv_open ext/gd/libgd/.libs/gdkanji.o
    libiconv ext/gd/libgd/.libs/gdkanji.o
    ld: fatal: Symbol referencing errors. No output written to sapi/cli/php
    collect2: ld returned 1 exit status
    *** Error code 1
    make: Fatal error: Command failed for target `sapi/cli/php'
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Jun 2007
    Posts
    1,513
    Rep Power
    1424
    Please export EXTRA_LIBS="-liconv" and try again.

    Regards, Jens
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2011
    Posts
    6
    Rep Power
    0
    thanks .. sorry m new to this...
    how to export .. can u please tell me ..
    in which file...?
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2011
    Posts
    6
    Rep Power
    0
    m getting the following error when i tried this command ..

    ./config.nice | grep iconv

    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: !: not found
    configure: warning: bison versions supported for regeneration of the Zend/PHP parsers: 1.28 1.35 1.75 1.875 2.0 2.1 2.2 2.3 2.4 2.4.1 (found: none).
    configure: warning: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
    ./configure: !: not found
    ./configure: !: not found
    ./configure: ./build/shtool: cannot execute
    checking for iconv support... yes
    ./configure: ./build/shtool: cannot execute
    checking for iconv... (cached) yes
    checking if iconv is glibc's... no
    checking if using GNU libiconv... no
    checking if iconv is Konstantin Chuguev's... no
    checking if iconv supports errno... no
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    configure: warning: lemon versions supported for regeneration of libsqlite parsers: 1.0 (found: none).
    ./configure: ./build/shtool: cannot execute
    checking iconv dir for XMLRPC-EPI... /usr/local
    configure: warning: bison versions supported for regeneration of the Zend/PHP parsers: 1.28 1.35 1.75 1.875 2.0 2.1 2.2 2.3 2.4 2.4.1 (found: none).
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute
    ./configure: ./build/shtool: cannot execute

    what does this error show...
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2011
    Posts
    6
    Rep Power
    0
    can u guide me where am i going wrong ..

IMN logo majestic logo threadwatch logo seochat tools logo