When trying to run Make after running Configure for GCC, I get this error:

Code:
checking for suffix of object files... configure: error: in `/bin/gcc/x86_64-unknown-linux-gnu/libgcc':
configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details.
make[2]: *** [configure-stage1-target-libgcc] Error 1
make[2]: Leaving directory `/bin/gcc'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory `/bin/gcc'
make: *** [all] Error 2
I look up the config.log file in /bin/gcc/x86_64-unknown-linux-gnu/libgcc and this is what I find:

Code:
configure:3246: checking for suffix of object files
configure:3268: /bin/gcc/./gcc/xgcc -B/bin/gcc/./gcc/ -B/usr/local/x86_64-unknown-linux-gnu/bin/ -B/usr/local/x86_64-unknown-linux-gnu/lib/ -isystem /usr/local/x86_64-unknown-linux-gnu/include -isystem /usr/local/x86_64-unknown-linux-gnu/sys-include    -c -g -O2  conftest.c >&5
/bin/gcc/./gcc/cc1: error while loading shared libraries: libmpc.so.2: cannot open shared object file: No such file or directory
The top of the config log file shows the options I used:

Code:
It was created by GNU C Runtime Library configure 1.0, which was
generated by GNU Autoconf 2.64.  Invocation command line was

  $ /root/installs/gcc-4.6.0/libgcc/configure --cache-file=./config.cache --enable-multilib --with-gmp=/usr/local --with-mpc-lib=/usr/local/lib --with-mpc-include=/usr/local/include --with-mpfr=/usr/local --with-libelf=/usr/local --enable-languages=c,c++,fortran,java,lto,objc --program-transform-name=s,y,y, --disable-option-checking --with-target-subdir=x86_64-unknown-linux-gnu --build=x86_64-unknown-linux-gnu --host=x86_64-unknown-linux-gnu --target=x86_64-unknown-linux-gnu --srcdir=/root/installs/gcc-4.6.0/libgcc --disable-intermodule --enable-checking=yes,types --disable-coverage --enable-languages=c,lto
If I am reading this correctly, in spite of the with-mpc options (I did try just --with-mpc=/usr/local in an earlier attempt), the Make is for some reason looking for the libmpc.so.2 file somewhere other than where it resides. In an attempt to resolve this, I created the directory structure listed in the error, but still got the same result. Any clues what I have done wrong and how to correct it?