Thread: remsh

    #1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Location
    Ireland
    Posts
    2
    Rep Power
    0

    Question remsh


    Hi .........

    I am trying to get remsh working from a Hpux 11.00 env to solaris 2.8 machine via a custom script.

    I can remsh between the servers, it's just when I do a remsh -n....

    rcmd: connect: mysolarishost: Connection refused ...

    My command

    remsh mysolarishost -n 'echo " My Command > /dev/null 2>&1" | at -s now'

    Any ideas on where i should be looking ??

    Thanks
    Alan
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    121
    Rep Power
    12
    I tried your command using the same two OS's and it worked for me.

    I think you're throwing a curve ball by mentioning -n. Consider the following 3 commands:

    remsh solarishost
    remsh solarishost "uname -a"
    remsh solarishost -n "uname -a"

    Are you really claiming that commands one and two work while command three fails? If so, this beats me.

    But command one uses the rlogin service while commands two and three use the rexec service. That would imply that rexec might not be enabled on solarishost. Check your /etc/inetd.conf to be sure that in.rexecd is enabled.

    Also could there be a firewall between the boxes? Could it be blocking rexec?

    And I guess that I should mention that it may be a good thing that it doesn't work. The berkeley r-commands are very insecure. ssh can do all of these things in a secure manner.
    Last edited by Perderabo; December 11th, 2003 at 09:14 PM.

IMN logo majestic logo threadwatch logo seochat tools logo