1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2004
    Rep Power

    Exclamation bash: setenv: command not found?

    I have to install a package on my computer. To make that package working, an environment variable must be added to the system. So, I tried the following command line:
    [root@localhost ref17-09-04]# setenv ZIPPER_PACK /mnt/winE/Programs/mesh/ref17-09-04/zipper-1.14/
    bash: setenv: command not found
    [root@localhost ref17-09-04]#
    I tried that command in many folders (/root/, …) but in vain.
    I can't understand why my system doesn't find even the help exists!!!
    In fact:
    [root@localhost ref17-09-04]# man setenv
    returns me the entire help...

    My OS is Linux Fedora Core 1.

    The same problem is faced with these commands too: environ, getenv, putenv, …

    Please help me to make that commands working.

  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Jul 2004
    Middle Europa
    Rep Power
    setenv is not a command, but a c-shell built-in function,
    i don't know if bash also uses it.
    in BOURNE sh: XXX=abc; export XXX; do-thejob
    in KORN sh: export XXX=abd; do-thejob
    in C-sh (the best on commando line) setenv XXX abc; do-thejob
    the best way works in bourne, korn, bash and cron:
    env XXX=abc do-thejob

IMN logo majestic logo threadwatch logo seochat tools logo