#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Posts
    2
    Rep Power
    0

    SCO and Print issue


    | I have a client with a SCO running on a Proliant 800 system, they run some kind of DB on it, during printing, system does not send form feed signal,i.e. if 2 documets sent, they are printed on same page. Does any one know what could be the problem and how to fix it. I have some knowlege of Linux but not SCO.

    # uname -X

    System = SCO_SV
    Node = scosysv
    Release = 3.2v5.0.5
    KernelID = 98/07/02
    Machine = PentII(D)
    BusType = ISA
    Serial = 2GA051257
    Users = 5-user
    OEM# = 0
    Origin# = 1
    NumCPU = 1

    #
    # lpstat -p -D
    l1:
    queuing is enabled
    l2:
    queuing is enabled
    #


    The database/program is AccuPlus ( no version) I called them and they claim that they have nothing to do with unix and this is a unix problem

    Thank you
    Al
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190

    Re: SCO and Print issue


    Originally posted by alexseys
    I called them and they claim that they have nothing to do with unix and this is a unix problem
    They're right. Printing in unix is usually not implemented in client programs, but they simply produce postscript output and pipe it to "lpr". The printer daemon ("lpd", "cupsd", ...) will take care of the rest.

    Edit your /etc/printcap file and remove the ":sf:" option ("suppress formfeed")

    hth,
    M.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Posts
    2
    Rep Power
    0

    Re: Re: SCO and Print issue


    Originally posted by M.Hirsch
    They're right. Printing in unix is usually not implemented in client programs, but they simply produce postscript output and pipe it to "lpr". The printer daemon ("lpd", "cupsd", ...) will take care of the rest.

    Edit your /etc/printcap file and remove the ":sf:" option ("suppress formfeed")

    hth,
    M.
    Here is the content of the file you point to I do not see what I should change on it Please advise

    # Remote Line Printer (BSD format)
    printer1:\
    :lp=:rm=lanpres1:ex:rp=l1:sd=/usr/spool/lpd/l1:mx#0:
    printer2:\
    :lp=:rm=lanpres1:ex:rp=l2:sd=/usr/spool/lpd/l2:mx#0:
    # #

    Thank You Al
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    The default in FreeBSD is "sf=false", not sure if SCO is different here. "man 5 printcap" will reveal this.
    I expected it to have a ":sf:" somewhere, but if SCO's default is "sf=true", you would have to add it:
    :lp=:rm=lanpres1:ex:rp=l1:sd=/usr/spool/lpd/l1:mx#0:sf:

    You are using a printer not attached to this machine, you probably have to set it up on the other machine where the printer is connected to. (In case it directly connects to your ethernet, try to telnet to it for configuration).

    hth,
    M.

IMN logo majestic logo threadwatch logo seochat tools logo