#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2004
    Posts
    29
    Rep Power
    0

    Library problem in HP-UX 11.31


    On HP-UX 11.31.

    when I compile my program, I get this:

    # make -f /comp/bin/proc.mk build INAME=pump.pc EXE=/var/tmp/pump_temp2 OBJS=pump.o #08/11/15 1:30PM#
    cc -o /var/tmp/pump_temp2 pump.o -L/lib/hpux64 -L/oracle/app/product/fmw11g/forms/lib/ -lclntsh `cat /oracle/app/product/fmw11g/fo
    rms/lib/ldflags` `cat /oracle/app/product/fmw11g/forms/lib/sysliblist` -lelf -lm -lrt
    ld: Unsatisfied symbol "mvwprintw" in file pump.o
    ld: Unsatisfied symbol "initscr" in file pump.o
    ld: Unsatisfied symbol "endwin" in file pump.o
    ld: Unsatisfied symbol "wgetstr" in file pump.o
    ld: Unsatisfied symbol "wnoutrefresh" in file pump.o
    ld: Unsatisfied symbol "mvprintw" in file pump.o
    ld: Unsatisfied symbol "wrefresh" in file pump.o
    ld: Unsatisfied symbol "noecho" in file pump.o
    ld: Unsatisfied symbol "wmove" in file pump.o
    ld: Unsatisfied symbol "echo" in file pump.o
    ld: Unsatisfied symbol "stdscr" in file pump.o
    ld: Unsatisfied symbol "mvaddstr" in file pump.o
    ld: Unsatisfied symbol "waddch" in file pump.o


    when I run it, I get this:

    /usr/lib/hpux64/dld.so: Unsatisfied data symbol 'stdscr' in load module '/var/tmp/pump_temp2'.
    zsh: killed /var/tmp/pum*temp*


    # ldd /var/tmp/pump_temp2 #08/11/15 2:05PM#

    libclntsh.so.11.1 => /oracle/app/product/fmw11g/forms/lib/libclntsh.so.11.1
    libdl.so.1 => /lib/hpux64/libdl.so.1
    libm.so.1 => /lib/hpux64/libm.so.1
    libpthread.so.1 => /lib/hpux64/libpthread.so.1
    libnsl.so.1 => /lib/hpux64/libnsl.so.1
    libunwind.so.1 => /lib/hpux64/libunwind.so.1
    libelf.so.1 => /lib/hpux64/libelf.so.1
    librt.so.1 => /lib/hpux64/librt.so.1
    libc.so.1 => /lib/hpux64/libc.so.1
    libnnz11.so => /oracle/app/product/fmw11g/forms/lib/libnnz11.so
    libdl.so.1 => /usr/lib/hpux64/libdl.so.1
    libm.so.1 => /usr/lib/hpux64/libm.so.1
    libpthread.so.1 => /usr/lib/hpux64/libpthread.so.1
    libnsl.so.1 => /usr/lib/hpux64/libnsl.so.1
    libunwind.so.1 => /usr/lib/hpux64/libunwind.so.1
    libc.so.1 => /usr/lib/hpux64/libc.so.1
    libxti.so.1 => /usr/lib/hpux64/libxti.so.1
    libuca.so.1 => /usr/lib/hpux64/libuca.so.1
    libdl.so.1 => /usr/lib/hpux64/libdl.so.1


    TI see it as a problem linking the curses library. This is all on HP-UX 11.31, with ncurses 5.9 installed. Using the native CC compiler.

    How can I fix this?
  2. #2
  3. Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Aug 2011
    Posts
    5,888
    Rep Power
    509
    was my answer to same question incorrect in c forum?
    [code]Code tags[/code] are essential for python code and Makefiles!
  4. #3
  5. Not An Expert
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2015
    Posts
    404
    Rep Power
    3
    Oof, I missed that these were the same.

    Please don't cross-post your questions, etcetera. Post it once where you think it will be most applicable, and if it needs to be moved you can always contact myself or a moderator to do so.

    Let's center the technical discussion over here: Problems linking curses library

    But I am also curious about why you cross-posted this question. You could explain that in this thread.

IMN logo majestic logo threadwatch logo seochat tools logo