#1
  1. sleeping guru
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Feb 2003
    Location
    under the stars
    Posts
    2,444
    Rep Power
    182

    I can't get the directories to not be read only


    Hey all,

    I have copied the Documents and Settings folder from one machine to another and now onto the new machine which has windows vista on it.

    But the files are all read only. So i right click>properties and uncheck the read-only box so it is completely clear and it says do i want to apply to all subfolders and files and i say yes...it seems to go through the process but then i go back after to check and it is REad-Only again

    any ideas?

    cheers,

    RF
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Sep 2003
    Location
    Oregon
    Posts
    2,154
    Rep Power
    938
    Been my experience all folders in XP and Vista are read only and there does not appear to be a way to change this display.

    This does not mean the files contained in them are read only. They are not. You can check by going to a files properties.
  4. #3
  5. Not much of a contributor
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Aug 2006
    Location
    Hidden
    Posts
    1,012
    Rep Power
    1096
    You have to change the ownership of that folder. You can do that by opening the folder properties, goto security then click advance. After that, go to owner tab then select your account then check the replace owner on subcontainers and object then click OK.

    NOTE: your account must be an administrative one.
  6. #4
  7. sleeping guru
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Feb 2003
    Location
    under the stars
    Posts
    2,444
    Rep Power
    182
    Hi Zynder,
    That is what i thought...but it doesn't seem to work
    It goes through the process, but makes no difference....

    @wanderer2 - i have tried renaming files/folders and it won't let me...so i guess it is read-only

    RF
  8. #5
  9. Not much of a contributor
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Aug 2006
    Location
    Hidden
    Posts
    1,012
    Rep Power
    1096
    Are you connected to a domain? I assume you're using an adminstrator account right?
  10. #6
  11. sleeping guru
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Feb 2003
    Location
    under the stars
    Posts
    2,444
    Rep Power
    182
    Originally Posted by zynder
    Are you connected to a domain? I assume you're using an adminstrator account right?
    no domain, just a workgroup. Yes using an administrative account..on Vista Business.
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Sep 2003
    Location
    Oregon
    Posts
    2,154
    Rep Power
    938
    Lets get specific. What folder in Vista are you working with? I have vista ultimate so we can compare.

    "i have tried renaming files/folders and it won't let me"

    Go to c:\temp
    Right mouse click and select "new"
    Do you get a list of all sorts of stuff like folder, file etc?

    What happens if you copy some of these files to your admin user folder and then change the ownership? can you set to not readonly then?
    Last edited by wanderer2; June 14th, 2007 at 05:59 PM.
  14. #8
  15. sleeping guru
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Feb 2003
    Location
    under the stars
    Posts
    2,444
    Rep Power
    182
    ok, i am working with Vista Business.

    Other folders are fine to rename and work with. It is JUST the one that i have dragged over from another machine....Documents and Settings

    thanks

    RF
  16. #9
  17. Providing fuel for space ships
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2004
    Location
    nr Edinburgh, Scotland
    Posts
    14,317
    Rep Power
    3852
    Sounds like a permissions issue to me. Generallly, 'Documents and Settings' folders are set to user accounts so you'll need an Admin account to take ownership of the files/folders.
    The No Ma'am commandments:

    1.) It is O.K. to call hooters 'knockers' and sometimes snack trays
    2.) It is wrong to be French
    3.) It is O.K. to put all bad people in a giant meat grinder
    4.) Lawyers, see rule 3
    5.) It is O.K. to drive a gas guzzler if it helps you get babes
    6.) Everyone should car pool but me
    7.) Bring back the word 'stewardesses'
    8.) Synchronized swimming is not a sport
    9.) Mud wrestling is a sport
  18. #10
  19. sleeping guru
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Feb 2003
    Location
    under the stars
    Posts
    2,444
    Rep Power
    182
    Originally Posted by aitken325i
    Sounds like a permissions issue to me. Generallly, 'Documents and Settings' folders are set to user accounts so you'll need an Admin account to take ownership of the files/folders.
    hey Aitken.

    Yeah as far as i am aware i am an admin on my vista machine...

    cheers

    rf
  20. #11
  21. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2005
    Location
    West London
    Posts
    278
    Rep Power
    15
    Your not the administrator on vista your just a power user, they use differnt names but Im just using that to keep it simple...

    First go show hidden files and folders
    Secound deleate any files that should not be in that folder like "Thumbs" or "Desktop" ect etc (I know these dont do much but delete them any way...
    Third select all files and untick read only
    cut these files and move them to a new folder that your vista computer has made.
    FourthRestart your computer and then you should be able to delete the other folder that was read only...

    that what I normally do when I get a problem like that...

IMN logo majestic logo threadwatch logo seochat tools logo