#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    50
    Rep Power
    15

    Cant start computer browser service.


    xp pro 2002 sp2

    Wow what a pain in the butt! Want to share files between desk and laptop. The desktop gains no access to workgroups.

    What I found out so far.
    Computer browser service must be enabled (preferably automatic). I get

    Could not start Computer Browser Service on Local Computer
    Error 1075: The dependancy service does not exist or has been marked for deletion.

    The service name is svchost.exe -k netsvcs

    One fix is
    After setting the restore point, to remove this dependency, do this:

    * Click: Start
    * Click: Run...
    * Type: regedit
    * Click: OK
    * Navigate to the following keys in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\DHCP
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NetBT
    * For each of these, on the right side, double-click: DependOnService
    * Delete any lines containing either SYMTDI or NISDRV.
    * Click: OK
    * Close the Registry Editor.
    * Reboot.

    Alright if I could find the right side double clickable option which I dont see anywhere in my registry edit,... damn.

    Any other fixes appreciated. Clean install would take me about 2 weeks to get all my appz reinstalled and fix disks have been a bad experience. Any other help most welcome.

    Thanx Chris
  2. #2
  3. duffy duck
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2006
    Posts
    205
    Rep Power
    63
    If you don't mind my asking what error is displayed in the event log when you try to start the computer browser service? Do you have any firewall like the SP2 firewall in place?

    Where did you get those instructions?
  4. #3
  5. Providing fuel for space ships
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2004
    Location
    nr Edinburgh, Scotland
    Posts
    14,317
    Rep Power
    3852
    Have you looked at the MS Knowledgebase ==> Clicky
    The No Ma'am commandments:

    1.) It is O.K. to call hooters 'knockers' and sometimes snack trays
    2.) It is wrong to be French
    3.) It is O.K. to put all bad people in a giant meat grinder
    4.) Lawyers, see rule 3
    5.) It is O.K. to drive a gas guzzler if it helps you get babes
    6.) Everyone should car pool but me
    7.) Bring back the word 'stewardesses'
    8.) Synchronized swimming is not a sport
    9.) Mud wrestling is a sport
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    50
    Rep Power
    15
    Originally Posted by aitken325i
    Have you looked at the MS Knowledgebase ==> Clicky
    Thanx aitken, was one of the first resources. msconfig showed other info so I didn't dare to run a command.
    Originally Posted by guest2006
    If you don't mind my asking what error is displayed in the event log when you try to start the computer browser service? Do you have any firewall like the SP2 firewall in place?

    Where did you get those instructions?
    The event viewer was usefull but in the registry editor I manage to find out right clicking on the right service informed me the LandmanServer was missing (its a coupleof days ago so forgive the typos) and the computer browser was dependant on that.

    I write this in case someone else encounters the same problem.

    By running the network wizard the LanmanServer reinstalled itself on my desktop computer, the laptop could already see the workgroup. So now both computers could see each other but could not transfer information or gain access to each other.

    I don't use the windows firewall but zonealarm free is up and running on both comps. I had to manually enter the ip of each comp as a trusted zone and bingo everything worked.

    Thanx for your help.
    Chris
  8. #5
  9. Who set my Title?
    Devshed Novice (500 - 999 posts)

    Join Date
    Jun 2004
    Posts
    715
    Rep Power
    262
    You can also disable simple file sharing in folder options to eliminate a lot of guess work. This will force XP Pro to use regular file sharing which does not depend on automatic detection and workgroup stuff.
    Nobody is perfect. I am Nobody.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    50
    Rep Power
    15
    Originally Posted by LaughingBelly
    You can also disable simple file sharing in folder options to eliminate a lot of guess work. This will force XP Pro to use regular file sharing which does not depend on automatic detection and workgroup stuff.
    Yeah I read this somewhere as well but not put so clearly. Probably the first thing I should have tried! Would have saved me 2 days of messing around.

    Thanx again for the support.

    Cheerio Chris

IMN logo majestic logo threadwatch logo seochat tools logo