Thread: USB dead?

    #1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    189
    Rep Power
    7

    USB dead?


    Hi, the topic says it all really, my USB is completely DEAD.

    However, some devices which are powered by USB (flash drives, keyboards etc) work fine.

    When i try my printer or my external HDD (which are powered by A/C power supply units) absolutely nothing happens.??

    Any ideas??

    Thank You!
  2. #2
  3. No Profile Picture
    Lost in code
    Devshed Supreme Being (6500+ posts)

    Join Date
    Dec 2004
    Posts
    8,317
    Rep Power
    7170
    Have you tried swapping the keyboard and printer ports to see if the issue only exists for certain ports? If this is the case, then the USB controller, probably on your motherboard, is dying. There's really no easy way to replace it, but you can buy USB controllers that interface over PCI. You could also just plug a hub into one of the working ports.

    It would be unusual for only externally powered devices to not work.

    If the problem doesn't seem to be tied to particular ports, download and burn a Linux live CD and see if you can get the HDD to show up on there. If you can, then it's a software issue with Windows. If you can't, then it might be a hardware issue.
    PHP FAQ

    Originally Posted by Spad
    Ah USB, the only rectangular connector where you have to make 3 attempts before you get it the right way around
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    189
    Rep Power
    7
    It appears to be solved with a windows update....atleast thats the last thing i did, then it worked!

    Thanks anyway!
  6. #4
  7. Providing fuel for space ships
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2004
    Location
    nr Edinburgh, Scotland
    Posts
    14,382
    Rep Power
    3848
    Out of curiosity, what was the update that you installed ?
    The No Ma'am commandments:

    1.) It is O.K. to call hooters 'knockers' and sometimes snack trays
    2.) It is wrong to be French
    3.) It is O.K. to put all bad people in a giant meat grinder
    4.) Lawyers, see rule 3
    5.) It is O.K. to drive a gas guzzler if it helps you get babes
    6.) Everyone should car pool but me
    7.) Bring back the word 'stewardesses'
    8.) Synchronized swimming is not a sport
    9.) Mud wrestling is a sport
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    You sure it didn't simply need a reboot? Sometimes I do...
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    2
    Rep Power
    0

    Wink The same problem


    Hi I had the same problem .... But after a complete reinstall system everything works fine....
  12. #7
  13. Providing fuel for space ships
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2004
    Location
    nr Edinburgh, Scotland
    Posts
    14,382
    Rep Power
    3848
    Originally Posted by HauckRa
    Hi I had the same problem .... But after a complete reinstall system everything works fine....
    A complete re-install would work, but it's a bit drastic until all the other options have been looked at don't you think!?
    The No Ma'am commandments:

    1.) It is O.K. to call hooters 'knockers' and sometimes snack trays
    2.) It is wrong to be French
    3.) It is O.K. to put all bad people in a giant meat grinder
    4.) Lawyers, see rule 3
    5.) It is O.K. to drive a gas guzzler if it helps you get babes
    6.) Everyone should car pool but me
    7.) Bring back the word 'stewardesses'
    8.) Synchronized swimming is not a sport
    9.) Mud wrestling is a sport
  14. #8
  15. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    189
    Rep Power
    7
    Lol yea espicially when its the last thing you find. Completely configured all roles, deployed websites etc etc, oh and then usbs dead....
  16. #9
  17. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2012
    Posts
    24
    Rep Power
    0
    One simple step of reinstalling would solve your problem. I also had the same problem like you are facing.
  18. #10
  19. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2008
    Posts
    189
    Rep Power
    7
    Originally Posted by khshoaib
    One simple step of reinstalling would solve your problem. I also had the same problem like you are facing.
    Nah sorted it without reinstalling.

IMN logo majestic logo threadwatch logo seochat tools logo