#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    259
    Rep Power
    0

    Windows optimization with temp folders


    Hi everyone, I have some questions about Windows 7 x64 optimization with TEMP folders. As I said, I have Windows 7 x64, and I have 2 SSD inside, the 1st one is the OS (the fastest one, a Samsung 840 PRO 256Gb) and the other one is the DATA drive, SSD Corsair Force 3 120Gb, (where I mainly store data, my users profiles, pagefile, etc.)

    I do this kind of setup mainly because I often reinstall and we are 5 using this machine (me, my wife and my 3 kids) and for optimization concerns. Me and my wife are both administrators while my kids are not.

    The main thing I do after installing Windows is;

    • Change the default user folders for each users (that's right, each movable folder in 'C:\Users\[USERNAME]\*' like 'Desktop', 'Contacts', 'Favorites', etc.). This prevents me from backing up each user folders everytime, it's on another drive, so I don't worry.


    • Change the pagefile location to secondary disk. I know this might be more suitable for ordinary, mechanical drives, but I do it anyway. So the pagefile is now on th 2nd SSD drive, in the root instead of my OS drive, I let Windows manage it, takes up 16Gb since I have 16Gb of memory. Does not bother me on the 2nd drive since I have plenty of space, but on my OS drive, 16Gb free is good!


    • Change default 'System variables' in the 'Environment variables to 2nd disk. This IS NOT User variables, but System variables, the 2nd box when clicking 'Environment variables'. 'User variables' will be covered in the next point. So, I move the following 2 folders ('TEMP' and 'TMP') to the 2nd disk, on the same folder : D:\Windows\TEMP. I make this to again save space on my OS drive and for optimization. I edit this on my account, and it makes the change for EVERY user, when I log on their sessions, I see the changes in the environment variables on the 'System variales'.


    • Ok, now the 'User variables', this is where it gets weird. I do the same thing, move the 'TEMP' and 'TMP' folders to the 2nd disk for, again, save space and optimization. I change the folder to 'D:\Users\[USERNAME]\TEMP' for both 'TEMP' and 'TMP' variables. This is user dependant, it's not like the previous one, you have to make the change for each user under their session. I made mine, it works, I made my wife, which is also an administrator, works fine..., but then my kids, who are not administrators..., I log on their sessions, when I try to open up the 'Environment variables', it asks for an administrator valid account to continue, that's ok with me, so I enter my account, and guess what? The 'User variables' in the box are not those of my kids, but mine, because I entered my credentials to see the 'User variables' window. So, here I am, I can't see or edit my kids 'User variables' since when I try to edit them, I have to authenticate myslef, and it takes my credentials to print the user variables... Is there a way to get around this??


    Thanks a lot!
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    Try using the setx command and see if that works for you.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    259
    Rep Power
    0
    Originally Posted by seack79
    Try using the setx command and see if that works for you.
    I think this will set the same user variables for all 5 accounts, ..., I think..., what I want is set a custom user variables folder for all my 5 accounts.

    Maybe the best way to do it would be to set them as admin to make the change and then send them back to non-admin accounts.

    Would that work?
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    259
    Rep Power
    0
    Found this : http://serverfault.com/questions/257...r-in-windows-7

    Will try it and come back once done if it works.
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    I was hoping the setx command would allow you to set it per user, at least from what I was reading on the TechNet article; perhaps not though.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    259
    Rep Power
    0
    I have not tried it, maybe it works, but from what I've read, or understood, maybe it's me, but it does not do what I want.

    thanks for your help
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    259
    Rep Power
    0
    Originally Posted by ExportA
    Found this : http://serverfault.com/questions/257...r-in-windows-7

    Will try it and come back once done if it works.
    Ok, it works, just tried it and it works!
  14. #8
  15. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    Nice work

IMN logo majestic logo threadwatch logo seochat tools logo