#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2002
    Location
    UK
    Posts
    76
    Rep Power
    13

    xslt is enabled but i get blank pages


    I installed sablotron xslt processor for php on my apache 2.0 installation.

    But when i try to view any page that has to go through xslt conversion i get a blank page.

    U can view my php installation here www.scs.dns2go.biz/phpinfo.php

    and im trying to use Krysalis application server but the index page for the web application just shows blank

    http://www.scs.dns2go.biz/krysalis/webapps/samples/

    username: admin
    pass : root

    any idea why i have to log in twice also ?
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2002
    Location
    UK
    Posts
    76
    Rep Power
    13
    This is what i found in apache's error log

    "PHP Notice: Undefined variable: action in /wwwroot/htdocs/krysalis/config/krysalis/index.php on line 22
    PHP Notice: Use of undefined constant KT_KRYSALIS_ROOT - assumed 'KT_KRYSALIS_ROOT' in /wwwroot/htdocs/krysalis/webapps/samples/config.inc.php on line 2
    PHP Notice: Use of undefined constant KT_LOCATION - assumed 'KT_LOCATION' in /wwwroot/htdocs/krysalis/webapps/samples/config.inc.php on line 3
    PHP Notice: Use of undefined constant KT_WEBAPP_ROOT - assumed 'KT_WEBAPP_ROOT' in /wwwroot/htdocs/krysalis/webapps/samples/config.inc.php on line 4
    PHP Notice: Use of undefined constant KT_LOG - assumed 'KT_LOG' in /wwwroot/htdocs/krysalis/webapps/samples/config.inc.php on line 5
    PHP Notice: Use of undefined constant KT_COMPACT - assumed 'KT_COMPACT' in /wwwroot/htdocs/krysalis/webapps/samples/config.inc.php on line 6
    PHP Notice: Use of undefined constant KT_PRODUCTION - assumed 'KT_PRODUCTION' in /wwwroot/htdocs/krysalis/webapps/samples/config.inc.php on line 7
    PHP Notice: Use of undefined constant KT_HOME - assumed 'KT_HOME' in /wwwroot/htdocs/krysalis/webapps/samples/index.php on line 11
    PHP Notice: Use of undefined constant KT_TAGLIBS_DIR - assumed 'KT_TAGLIBS_DIR' in /wwwroot/htdocs/krysalis/webapps/samples/index.php on line 12
    PHP Notice: Use of undefined constant KT_COMPONENTS_DIR - assumed 'KT_COMPONENTS_DIR' in /wwwroot/htdocs/krysalis/webapps/samples/index.php on line 13
    PHP Notice: Use of undefined constant ADODB_DIR - assumed 'ADODB_DIR' in /wwwroot/htdocs/krysalis/webapps/samples/index.php on line 14
    PHP Notice: Use of undefined constant KT_CONNECTION_DIR - assumed 'KT_CONNECTION_DIR' in /wwwroot/htdocs/krysalis/webapps/samples/index.php on line 15
    PHP Notice: Use of undefined constant KT_PDFReportsLite_DIR - assumed 'KT_PDFReportsLite_DIR' in /wwwroot/htdocs/krysalis/webapps/samples/index.php on line$
    PHP Notice: Use of undefined constant KT_LIB_DIR - assumed 'KT_LIB_DIR' in /wwwroot/htdocs/krysalis/webapps/samples/index.php on line 17
    PHP Notice: Use of undefined constant KT_CACHE_DIR - assumed 'KT_CACHE_DIR' in /wwwroot/htdocs/krysalis/webapps/samples/index.php on line 18
    PHP Notice: Use of undefined constant KT_LOG_DIR - assumed 'KT_LOG_DIR' in /wwwroot/htdocs/krysalis/webapps/samples/index.php on line 19
    PHP Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration$
    PHP Fatal error: Call to a member function on a non-object in /wwwroot/htdocs/krysalis/resources/lib/interakt/XMLParser.inc.php on line 180 "
  4. #3
  5. a lazy guy
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2001
    Location
    Hong Kong
    Posts
    99
    Rep Power
    14
    eemo,

    when XSLT goes into a blank page...
    it is usually
    1) there is syntax error of your XSL file. Check it by opening it on your IE5.5+ browser.
    2) XML error (eg. missed CDATA tag, missed xml header...etc)

    if your problem still couldnt be fixed, post your xml and xsl file here. 8)
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2002
    Location
    UK
    Posts
    76
    Rep Power
    13
    but it cant be anything to do with my server setup right ?
    like sablotron, or apache ?
  8. #5
  9. a lazy guy
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2001
    Location
    Hong Kong
    Posts
    99
    Rep Power
    14
    from your phpinfo,
    it prints
    XSLT support enabled.

    I think your XSLT should work.
    Perhaps u should try a simple XSLT first.

    I have enclosed a very simply XSLT php codes
    place them in your www folder, and try execute test.php.
    Attached Files

IMN logo majestic logo threadwatch logo seochat tools logo